AmazonLinuxにmod_sslをインストール

表題の通り。

■ 環境

  • Apache httpd 2.4.27
  • Amazon Linux

■ mod_ssl

SSLのモジュールを入れたかったのだが、パッケージ名がわからず四苦八苦。

$ sudo yum install mod_ssl
Resolving Dependencies
  :
Error: httpd24-tools conflicts with httpd-tools-2.2.32-1.9.amzn1.x86_64
Error: httpd24 conflicts with httpd-2.2.32-1.9.amzn1.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
$

確かにインストールしたい環境は”httpd24“を入れている。

$ sudo yum search mod_ssl
Loaded plugins: priorities, update-motd, upgrade-helper
================ N/S matched: mod_ssl ================
mod_ssl.x86_64 : SSL/TLS module for the Apache HTTP Server

  Name and summary matches only, use "search all" for everything.
$

さてパッケージ名はなんであろうかと考える。

$ sudo yum search ssl
================ N/S matched: mod_ssl ================
  :
mod24_ssl.x86_64 : SSL/TLS module for the Apache HTTP Server
mod_ssl.x86_64 : SSL/TLS module for the Apache HTTP Server
  :
$

どうやらこれが正解のようである。

$ sudo yum install mod24_ssl

これでインストールができた。満足である。

以上。

コメントを残す

メールアドレスが公開されることはありません。

CAPTCHA


このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください